Fast.ai v2 environment set-up on Google Cloud


#21

Hey @JamesCiao, sometimes it might be better to just delete your instance and your disk and run it all over again. If your install script didn’t run correctly the last time it might have actually written some stuff onto your disk during some of your initial tries. Which might be causing problems for your future attempts to install stuff.

Try deleting your VM instance, and disk (I think it’s menu >> Compute Engine >> VM Instance) then delete your instance. Do the same for in menu button >> Compute Engine >> Disks to make sure the disk is deleted too.


#22

Hey guys. I set up my GCP as per the link
https://medium.com/@howkhang/ultimate-guide-to-setting-up-a-google-cloud-machine-for-fast-ai-version-2-f374208be43.
I am unable to run the step 11 to run the bash script. Its giving me an error saying bash is not recognized as an internal or external command, operable program or batch file. what should I do?


#23

Is it possible to send us a screenshot? We need more information to troubleshoot.


#24

Hi guys, do you have any idea how to locate my fastai instance? why does it say no file or directory?


#25


#26


#27

Guys I tried running it again and as of now, its running the command. Thanks and sorry for the trouble.


#28

OK. Just in case someone else encounter the same issue as yours, I will try to explain the problem and solution here. Your first screenshot showed what caused the problem. You are unable to run the curl setup.sh | bash command because you are running it on your local machine. The command only works if you run it in the Google Cloud VM after you successfully SSH into it.


#29

In the glcoud compute ssh command, you are supposed to replace the placeholder <fastai-instance-1> with the Google Cloud VM instance name. You can locate it in your Google Cloud Console.

Example:

my instance name: ubuntu-dl-box

gcloud compute ssh ubuntu-dl-box


#30

hi cedric, fastai-instance-1 is my instance name on Gcloud vm


#31

I see. The syntax in your command is wrong:

gcloud compute ssh <fastai-instance-1> --ssh-flag="-L" --ssh-flag="8888:localhost:8888"

Remove the < and > surrounding your instance name. Change your command to:
gcloud compute ssh fastai-instance-1 --ssh-flag="-L" --ssh-flag="8888:localhost:8888"

I noticed a potential problem when the double quotation marks are not consistent/same. Ensure you don’t mix straight double quote " " with curly double quote “ ”.


#32

@cedric thanks!! i followed your steps but i got another error as seen below:
error

would this be due to some gcloud auth login problem? this is already my active acccount, but i don’t know why this doesnt work? any solutions to this?


#33

Could you try the command without those ssh-flag like this?
gcloud compute ssh fastai-instance-1

I am not sure why is there a need for those flags. At least, it worked for me without those flags. My desktop is running Ubuntu, not Windows like your case. If you really need those flags, I have checked the gcloud command documentation. What those ssh-flag is doing is passing arguments (options) to the SSH client. In your case, it is trying to do SSH port forwarding.

I suspect localhost in the 8888:localhost:8888 should be replaced with your Google Cloud instance public IP. Otherwise, you will see the error you are seeing Insufficient Permission. I am not so sure though. You can try a few things that I mentioned to see if it helps resolve the problem.


#34

Looks like you are already in your instance.

You’ll the change of your alias ((fastai) [email protected]) when you are in.


#35

I am getting the below error Message. Please help

(fastai) [email protected]:~$ gcloud compute ssh instance-1 --ssh-flag=“-L” --ssh-flag=“8888:localhost:8888”
ERROR: (gcloud.compute.ssh) Failed to read command line argument [–ssh-flag=“-L”] because it does not appear to be
valid 7-bit ASCII.
gcloud compute ssh instance-1 --ssh-flag=“-L” --ssh-flag=“8888:localhost:8888”
^ invalid character


#36

Thank you for your help! @cedric@jameslee I’ve managed to get my system up and running, although i eventually decided to recreate my instance haha


#37

@JarylLim @cedric Myself also getting the insufficient permission now. Can you please let me know the exact steps that you followed to resolve it.


#38

What worked for me was deleting my current instance and subsequently recreating it; I spent quite some time trying to figure how to resolve these errors to no avail.


#39

Hi I followed How Khang’s guide above, and tried to create a VM on google cloud, but I got this error when I tried to start it:

The request contains invalid arguments: “Instances with guest accelerators do not support live migration.”. Error code: “badRequest”

Does anyone know how to resolve it? I had a previous VM which could run, but had many problems with running the fastai jupyter notebooks, and How Khang suggested I delete my VM and recreate it. Thats what I did but now I have this error >< Its really frustrating to receive so many errors again and again, I a beginner in AI, so I really hoping to learn a lot form the session one lessons, but I keep on running into so many problems which is really discouraging.

If anyone can help, I would appreciate it a lot!


#40

Hey Jonathan,
Can you come earlier at 9.30am tomorrow to the SGInnovate venue? Mentors will be available onsite to help.

Cheers,
Jia Qing