Fast.ai v2 environment set-up on Google Cloud


#41

Hey guys,

I came to step 13 method 2. However my local browser cannot connect to server. And server side show refusing connect info as below:

Can experts help me see what would be the problem? @yapjiaqing @jameslee

Thanks!


#42

OK I think I accidentally close the terminal which opens jupyter notebook. I re-operate step 12 then the page can open.


#43

Hey man,

did you resolve the issue? I have the same problem.
I tried to forward the port. but get below error message

ERROR: (gcloud.compute.ssh) Failed to read command line argument [–ssh-flag=“-L”] because it does not appear to be valid 7-bit ASCII.

gcloud compute ssh highland --ssh-flag=“-L” --ssh-flag=“8888:localhost:8888”
^ invalid character/

now i get it.

Fast.ai v2 environment set-up on Google Cloud

Thank you everyone!!!


#44

Hey man, I got the same problem, how did you resolve this?

hey man i just solved this problem, the glitch lies in the

"

and

it is a tiny difference, use the one in the front


#45

Why are we applying for paid version if google already giviing us 300$ credit to run gpu


#46

They only give GPU quotas to a paid version of the account. You wont be charged unitl your credit runs out. So be sure to turn off your instance when you are not using it!


#47

Hi All,
I m trying to run instance on Gcloud, it is shooting me site cant be reached

anyone faced the same error …how to resolve it?


#48

Hey @SeemaGoel, which guide are you following? Sometimes it’s a permissions issues - try sudo chown -R username:username .jupyter where username is your google cloud platform username


#49

@jameslee I am following

https://medium.com/@howkhang/ultimate-guide-to-setting-up-a-google-cloud-machine-for-fast-ai-version-2-f374208be43


#50

tried doing sudo chown but same error:

I am using static IP


#51

I noticed the Jupyter Notebook URL is using https. Try with http://104.199.190.183:8888 Also, ensure that there is no browser extension/plugin for example, “HTTPS Everywhere” interfering with the normal working of the browser.


#52

Thanks, @cedric,
the error was in firewall settings where it “Action on match” was deny…not Allow.
I deleted the settings and created new one with “Action on match” as Allow


#53

I see. :thinking: strange. Glad that you managed to resolve the issue.


#54

Sorry for the late response, but thanks for your message. How Khang helped me to fix it. Apparently I had to reinstall everything. Yup I came early too, in case I needed more help heh.


#56

I tried to add additional quota for K80 GPU as in the guide provided but I received an email asking me to transfer some money to increase the quota. For your information, I have not set up any virtual machine instances before requesting for quota expansion.


#57

It seems like there have been a few cases where Google is asking for a payment from you before being allocated any GPU quote. I’ve heard of people having to pay either 35usd or 70usd for it.

Honestly, I think it’s pretty bad that Google is asking for a payment before allowing us to use the free credits. Maybe email support and see what’s up?


#58

James Lee, I would like to ask if anyone else also suffers from the same problem ?


#59

I know of 2 people so far, although I don’t think they’re active on this forum space.

I didn’t have to pay though. :confused:


#60

Regarding the other one, when did he/she encountered the problem ? Maybe Google may have changed the policy ?


#61

I think in December, and one more a few weeks back. I don’t think they’ve changed their way of doing this since.